Saturday, September 05, 2009

Future Firefox Checks Outdated Flash Player

According to a blog post on Planet Mozilla by Johnathan Nightingale, it seems that future Firefox (starting Firefox 3.5.3 and Firefox 3.0.14) will check for Adobe Flash Player Plugin installed on user's system and notified them if the version is outdated. Old version may cause some problem, mostly security problems, so Mozilla team takes this matter seriously.

This action is chosen after a recent studies at h-online which states 80% of the users are running old version of Adobe Flash Player.

After installing the Firefox security update, users with fully updated flash player will get a regular screen, but users with an outdated version of the Adobe Flash Player will see this message: