Sunday, May 20, 2012

Suhosin On PHP 5.4.3

Today, i cloned Suhosin tree at github because i wanted to try compiling it for my machine which is running PHP 5.4.3. As you recall, suhosin wasn't compatible with PHP 5.4 since there were a lot of changes introduced in PHP which caused it broken.

Steffan has started an initial steps to make Suhosin compilable with PHP 5.4 and he addressed any issues so quickly. I submitted an issue and in less than 24 hours, my issue has been fixed in the upstream tree and now Suhosin compiles on my machine running PHP 5.4.3. Looking forward to implement Suhosin on my other machines.