Wednesday, July 08, 2009

Firefox 3.5 and Libsafe

I have had problem with Firefox 3.5 on my Linux box (laptop). I finally solved this problem by commenting libsafe entry on /etc/ (Thanks to olego from LQ who posted the solution).

What makes me curious is that why does Firefox does not work with libsafe? Libsafe works by replacing insecure C functions with secured one, and with libsafe installed, it does not work at my system. Does that mean Firefox has used insecure functions on the code? Or is it libsafe that is considered outdated and does not work with newer applications?